Group Details

Sergeant

Enlisted personnel with the rank of Sergeant.

Member List

skdwyer17
Steven7
mawk
rmcnelis
goosejuice
MrWhiteman
Inz68
zuludunba
silent
Bart
josiewales
clemsafe
KurtHossinger
trey1112006
SaintBernard
Anubite
Grabaman
JackD
trajan

Latest Posts

rmcnelis

Trying to create single player game, but site just shows busy and does not create

posted in Bug Reports read more

rmcnelis

Solo games have no options to choose.

posted in Bug Reports read more

Grabaman

I rolled Win 10 back to the previous version and it works now. But eventually will have to accept Win 10 update.

Probably beyond the scope of BF Admin to fix this. In case someone else has this problem at least Admin will have a temporary remedy. Hope Microsoft can fix eventually.

posted in Bug Reports read more

Grabaman

Forgot to add current game info.
Four Human Standard World #331365633

Previewing other games also gives blank/white screen.

posted in Bug Reports read more

Grabaman

I just ran windows latest updates and now all the maps are not viewable. I just get a white screen. The game heading and the Game Chat still work. I uninstalled the updates, but still no maps. Same problem in Edge and Chrome.

I looked up the problems with Windows Creator Update and Adobe Flash Player, but it is enabled and is not giving me any messages about blocking it.

Have restarted several times. Computer is <2yrs old, i5-5400, 500GB SSD (200GB used), 16GB RAM, runs everything great. HELP!!!

posted in Bug Reports read more

Grabaman

Hello Admin. The game is essentially shut down. Nobody can submit a turn.

posted in Bug Reports read more

Grabaman

Same here.

posted in Bug Reports read more

Grabaman

It's working fine now. Must have just been my PC for that day.

posted in Bug Reports read more

Grabaman

Additional: Seems to be all standard world maps. Not affecting other maps.

posted in Bug Reports read more

Grabaman

10 Human Epic Battle #709706951

The borders are not showing up on bottom half of map (more like 60%). Tried refreshing, and even waited about 12hrs to try again. Same problem.
Not sure if it's just me.

posted in Bug Reports read more